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1. Introduction 

The document is written for those who want to learn about CandleQuote application – tool allowing you to easily get 

free market quotes data from multiple data providers and export it to your favourite technical analysis application. 

You can find in this document all necessary informations on how to buy, install and use the application. If you need 

more help please send us an email at contact@candlescanner.com.  

Buying license of CandleQuote you gain the following: 

 lifetime license 

 free upgrades for 12 months since the date of purchase 

 free technical support for 12 months since the date of purchase 

 

For latest information on CandleQuote please visit our website at candlescanner.com and our YouTube channel at 

https://www.youtube.com/user/CandleScanner. 

 

Disclaimer 

CandleQuote is fully dependent on the external data providers. 

Please note that buying CandleQuote you are not buying data as such which at the moment is free of charge and is 

not a property of LEMPART company.  

We are not responsible for the data quality or its availability. We also do not guarantee that data provided by will 

remain free in the future.  

Buying CandleQuote you agree with all these conditions and restrictions. No refunds will be given after buying the 

application. 

Full text of Terms & Conditions for Ordering and Using LEMPART software you can find at: 

https://candlescanner.com/terms_and_conditions. 

2. Technical requirements 

In order to successfully run and use the CandleQuote application you need to have a computer with one of the 

following operating systems:  

 Windows 7 (any edition) 

 Windows 8 (any edition) 

 Windows 10 (any edition) 

Both versions are supported: 32-bit and 64-bit. 

Additionally you need to have .NET Framework 4.0 or above installed on your computer. If this is not the case please 

visit http://microsoft.com website to download it and install it first on your machine prior installing CandleQuote. 

mailto:contact@candlescanner.com
https://www.youtube.com/user/CandleScanner
https://candlescanner.com/terms_and_conditions
http://microsoft.com/
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3. Purchasing and installation process 

Creating user’s account 

In order to buy CandleQuote please visit our online shop at: http://shop.candlescanner.com/ 

WARNING! 

We deeply encourage you to download free trial version (fully operational for 7 days) and see if the 

application suits your expectations and needs. There are no refunds for already bought license. 

Installing your application 

In order to start installation of CandleQuote you need to download it first (link may be found at our online shop 

http://shop.candlescanner.com). After successful download of the installation file you need to run it (double click on 

it). The process is very straightforward and does not require any specific technical knowledge from the user. Simply 

follow the steps as they are displayed on the screen.  

WARNING! 

 If the user will not select the option to run the application automatically after installation ends, the first start 

of the application has to be performed with the rights of Administrator user. In order to do it you need to 

right-click on the application icon and select the option Run as administrator. 

 

WARNING! 

 While downloading the file you may see warnings from your operating system that the file to be downloaded 

is potentially dangerous for your computer. All files downloaded from http://candlescanner.com are digitally 

signed giving you guarantee that are absolutely secure for your machine and were not tampered by anyone. 

In order to check if the downloaded file is digitally signed right click on it, select Properties and then go to 

Digital Signatures tab which contains the details of the digital signature. If the Digital Signatures tab does 

not exist it means that file is not signed by LEMPART company and can be potentially dangerous (could be 

tampered by anyone). 

 

When the user starts the CandleQuote for the first time he/she will be asked to provide registration data first. This is 

exactly the same data which was used during opening an account on the website in order to buy the product. 

 

http://shop.candlescanner.com/
http://candlescanner.com/
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Figure - First run of CandleQuote after installation requires entering registration data. 

 

Upgrading your application 

Whenever newer version is available for download you can simply perform the same steps as for normal installation. 

It is recommended to remove first the existing application to avoid any problems or conflicts with existing 

application. Before this we highly recommend to backup any files or settings from your existing installation. 

Uninstalling your application 

Your application can be easily removed from your computer via Control Panel of your operating system: Control 

Panel -> Uninstall a program, select the CandleQuote and press Uninstall button. Follow instructions to complete 

the process. 

4. User interface 

Main functionality 

Basically all the core functionality of CandleQuote is reachable from the File menu. 
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Figure - File menu: from here you can perform all CandleQuote operations: import, export and update quotes data. 

 

The main functionality of CandleQuote is: 

 Importing quotes data. This is step in which user specifies what data he would like to download. You need to 

provide a list of symbol to be downloaded (either manually, or from an external file). CandleQuote supports 

following data providers: 

o YAHOO! Finance (end-of-day) 

o Quandl (end-of-day, intraday) 

o Tiingo (end-of-day, intraday) 

o Alpha Vantage (end-of-day, intraday)  

o Stooq (end-of-day) 

 Updating quotes data. Once data is added (imported) to CandleQuote you can update it with the latest 

quotes. 

 Exporting quotes data. Although you can view the content of the downloaded data directly in CandleQuote, 

most probably you want to export it to some external files which then can be imported to your application 

like CandleScanner, MetaStock, WealthLab, AmiBroker or any other which supports ASCII files or MetaStock 

files.  

Updating and exporting may be automated. For example you may want to update forex data every 5 minutes, and 

export it to some folder on your hard drive. Then such folder may be read by any technical analysis software and 

update itself. 

CandleQuote uses the notion of symbols group which is a logical place where you can store imported data in an 

ordered manner.  

Group can be added either by right-clicking within Symbols group area or while running data import wizards. 

You can think of CandleQuote group as of folders (directories) in your operating system where you store your files 

(called symbols in CandleQuote terminology). For example you can decide to create NASDAQ group where you 

import all the components (symbols) from this index. You can move symbols between groups similarly as you can 

move files between folders in your operating system. You also can remove (delete) symbol from the group. Groups 

can be also renamed. 
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Figure - Main window of CandleQuote. 

 

Please note that symbols have to be unique within groups. In the Symbols area on the main screen you see symbols 

from the selected group. Symbols have an additional property – name. This is a more descriptive than symbol (ticker) 

text string, which does not have to be unique within group (although it can be ambiguous and should be avoided if 

possible). 

 

WARNING! 

All tabs and windows within CandleQuote can be dragged and dropped to either use it outside the main 

window or change the layout to meet your specific needs. You can always come back to original default layout 

settings via menu Window -> Reset window layout. 

Adding defined symbols 

Below you can find a procedure to get a data from YAHOO! Finance. Defined list is available currently only for 

YAHOO! Fianance. 

This method of adding (importing) data to CandleQuote is reachable from File -> Add new symbols from YAHOO! 

Finance – defined symbols.  

This method of importing data is the easiest and contains predefined (built-in) list of components grouped by 

markets. You simply can choose for example NASDAQ as a market and then select which companies you want to 

import to CandleQuote. You can also specify the date from which you want to import data. You need to also specify 

to which group you want to import data in CandleQuote. At the end of import process summary report is displayed 

to see if there were any problems with data download from YAHOO! Finance. 
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The drawback of this method may be however that the list can be outdated. Companies are constantly being added 

or removed from certain exchanges/markets. CandleQuote is released with the latest snapshot of the markets but 

after some time it can be obsolete. If you find this is the case then you can either to update CandleQuote to newer 

version (if available) or use the other method of import described in the next section Adding symbols based on 

user’s list. 

 

 

Figure - Wizard for importing quotes data based on the predefined (built-in) list. 

 

WARNING! 

Importing huge volume of data can be very time-consuming (even hours). If you are sure that you do not need 

certain markets/components it is better to remove them from the import process. Also in the future when you 

want to update existing data in CandleQuote the process is faster if there are fewer components to be 

updated. 

 

Adding symbols based on user’s list 

Below you can find a procedure of loading data from user's list. It is common for all data providers, although we 

present example using YAHOO! Finance. 

This method of adding (importing) data to CandleQuote is reachable from File -> Add new symbols from YAHOO! 

Finance – user’s symbols.  

Although this method of data import from YAHOO! Finance may seem a bit complex at first sight it is the most 

flexible and powerful method. As mentioned in the previous section, importing data based on predefined symbols 

can lead to not importing all data when the list is outdated. This can be avoided using our own external file with 

defined list of symbols we want to import to CandleQuote or entering this list manually directly in the CandleQuote 

wizard. 
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Figure - Wizard for importing quotes data based on the manually provided list (either from external file or entered manually). 

 

When you run this wizard in the first step you need to decide whether you want to use external file all enter data 

manually. In both cases data you want to import need to be in the form of: 

<Symbol (ticker)> <separator> <Symbol name> 

As a separator you can use one of the following characters: 

| (pipe) 

; (semicolon) 

tab (tabulator key) 

For example you can create an ASCII text file (with any file extension as long as it is a plain text file) with the 

following content: 

AA Alcoa Inc. 

AXP American Express Company 

BA The Boeing Company 

BAC Bank of America Corporation 

CAT Caterpillar Inc. 

CSCO Cisco Systems, Inc. 

CVX Chevron Corporation 

DD E. I. du Pont de Nemours and Company 

DIS The Walt Disney Company 

GE General Electric Company 

HD The Home Depot, Inc. 
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You can also enter this manually in the wizard if you selected this option at the beginning upon import. 

Please note that in the example we used as a separator tab character. Although it may look like a number of spaces 

they are not created by pressing space button on the keyboard. 

 

WARNING! 

While using as a separator tabulation character please pay attention that only single tabulation character can 

be used. The lines where more than one tabulation character is used will be skipped during import process. 

The same applies to lines where illegal character is used as a separator (e.g. white space character). 

Updating data 

 

Figure - Wizard for updating imported data. 

 

Once you have some data imported in CandleQuote you may want to update it. This operation is very 

straightforward and can be performed via File -> Update data.  

 

WARNING! 

Updating huge volume of data can be very time-consuming (even hours). If you are sure that you do not need 

certain markets/components it is better to remove them from group(s) what can accelerate updating process.  
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Exporting data to CandleScanner format 

Imported data in CandleQuote can be exported to CandleScanner format. Technically the output format is saved as 

ASCII file, but in the way which enables in a very simple manner import it to CandleScanner application. If you are 

using CandleScanner you can export data using this method File -> Export data to CandleScanner format. Then in 

CandleScanner you select Import data from CandleQuote and specify the directory where your exported data is 

located. Although files being imported are in ASCII format you do not have to specify any further details in 

CandleScanner. 

Exporting data to MetaStock format 

Imported data in CandleQuote can be exported to MetaStock® binary format which is used by many charting and 

technical analysis applications.  

Exporting data to MetaStock format can be performed via File -> Export data to MetaStock format.  

 

Figure - Wizard for exporting quotes data to MetaStock binary format. 

 

All you need to do is to specify which group you want to save in MetaStock format and where to save it on your local 

hard drive. 

At the end of export you can save the settings (output format, location and group) as an export schema. For more 

details please see Automating exporting process using schemas section.  
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Exporting data to text files (ASCII format) 

Imported data in CandleQuote can be exported to ASCII format (plain text) which is used by many charting and 

technical analysis applications.  

Exporting data to text format can be performed via File -> Export data to text file.  

You need to specify the format of output text file. It may depend on your specific needs or your software 

requirements. 

At the end of export you can save the settings (output format, location and group) as an export schema. For more 

details please see Automating exporting process using schemas section.  

 

 

Figure - Wizard for exporting quotes data to ASCII files (plain text files). 

 

Automating exporting process using schemas 

When you export to MetaStock, ASCII or CandleScanner format at the end of the process you can save used setting 

as an export schema. This may be very useful because next time when you want to export some data you do not 

have to specify again the same details and just use previously defined schema. Using schemas has also one additional 

benefit – you can specify that while exporting data you want to update them first. This way you can very quickly 

export latest data minimizing the required number of steps to be performed. 

Automated exporting may be scheduled, so that it will be repeated for example every 5 minutes or any other time 

interval. 
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5. Troubleshooting 

PROBLEM SOLUTION 
My symbol is not updated with the latest 
quotes. 

From time to time there are some delays on the data provider's 
side and the latest quotes are not available. Please try the 
update process at later time. 

The symbol I am looking for cannot be found. Unfortunately not always you can get everything.  

I cannot start the application after installation. If you have not run the application automatically at the end of 
installation process then when you click on the CandleQuote 
icon you will not be able to run it at the first time. You need to 
right-click on the CandleQuote icon and select Run as 
administrator. This is required only for the first time when 
application asks you for registration data. Next time you can 
simply start the application without administrator privileges as 
any other application. 

6. Frequently Asked Questions (FAQ) 

 

What is CandleQuote? 

CandleQuote is a tool allowing you to download free end-of-day (EOD) and delayed intraday data from YAHOO! 

Finance, Tiingo, Quandl, Alpha Vantage and Stooq. Downloaded data is written in form of a text file (ASCII file). This 

data is compatible with any trading tool supporting ASCII files 

 

Which data I can download using CandleQuote? 

You can download actually any quotes which are provided by YAHOO! Finance, Tiingo, Quandl, Alpha Vantage and 

Stooq. There are indices, currencies, commodities, futures, stocks and bonds worldwide. 

 

Will my application be able to read data downloaded by CandleQuote? 

Any application which supports ASCII files or MetaStock format is able to read data provided by CandleQuote. 

 

How much does it cost and how to buy it? 

You pay for CandleQuote 99 USD. And this is one-time fee. So you have application for whole life. Also within first 

year you have free updates (if any are released). Before buying we encourage you to download trial version to see if 

it suit you. No refunds for bought applications are granted. 

 

Is there a trial version? 

Yes, there is. Please navigate to main page at https://candlescanner.com.  
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How long I can use trial version? 

Trial version can be used for 7 days period. This is more than enough to see if it is suitable for you. During this period 

of time CandleQuote is fully operational without any limitations in comparison to full version. 

 


